Document Title: =============== QuickerBB 0.7.0 - Register Cross Site Scripting Vulnerability References (Source): ==================== http://www.vulnerability-lab.com/get_content.php?id=1895 Release Date: ============= 2016-08-11 Vulnerability Laboratory ID (VL-ID): ==================================== 1895 Common Vulnerability Scoring System: ==================================== 3.2 Product & Service Introduction: =============================== QuickerBB is a fast forum. It is based on PHP5 with databases SQLite and MySQL via PDO. The easy setup forum web-application is in use by several tor protected shopping websites. (Copy of the Homepage: http://188.122.128.27/index.php ) Abstract Advisory Information: ============================== The vulnerbaility laboratory core research team discovered multiple client-side cross site vulnerabilities in the QuickerBB v0.7.0 Forum web-application. Vulnerability Disclosure Timeline: ================================== 2016-08-11: Public Disclosure (Vulnerability Laboratory) Discovery Status: ================= Published Affected Product(s): ==================== QuickerBB Product: QuickerBB - Forum (Web-Application) 0.7.0 and 0.6.0 Exploitation Technique: ======================= Remote Severity Level: =============== Medium Technical Details & Description: ================================ Multiple client-side cross site scripting vulnerabilities has been discovered in the QuickerBB v0.7.0 Forum web-application. The vulnerability allows remote attackers to inject own malicious script codes to client-side browser to web-application requests. The cross site scripting vulnerabilities are located in the `username` and `email` parameters of the `Register` module. Remote attackers are able to inject own malicious payloads to the client-side requested register module of the index.php file. The injection points are the vulnerable marked parameters and the execution point occurs in the forum registration form web context. The request method to inject is POST and the attack vector of the issue is non-persistent. The security risk of the xss vulnerabilities are estimated as medium with a cvss (common vulnerability scoring system) count of 3.2. Exploitation of the client-side vulnerabilities requires no privileged web-application user account and only low user interaction. Successful exploitation of the vulnerability results in non-persistent phishing attacks, session hijacking, non-persistent external redirect to malicious sources and non-persistent manipulation of affected or connected web module context. Request Method(s): [+] POST Vulnerable Module(s): [+] Register Vulnerable File(s): [+] index.php Vulnerable Parameter(s): [+] username [+] email Proof of Concept (PoC): ======================= The client-side vulnerabilities can be exploited by remote attackers without privileged user account and with low user interaction. For security demonstration or to reproduce the vulnerability follow the provided information and steps below to continue. Manual steps to reprduce the vulnerability ... 1. Open the forum web-application without authentication 2. Open the register module with click to the link 3. Inject to the username or email inputs own script code payload 4. The execute occurs when processing to click the submit button for the POST method request 5. Successful reproduce of the client-side cross site scripting web vulnerability! PoC: Vulnerable Source (./index.php?act=register)
QuickerBB fast forum software
Home => Register
Error with Username, Password or Email. --- PoC Session Logs [POST] --- Status: 200[OK] POST http://quickerbb.localhost:8080/index.php?act=register Mime Type[text/html] Request Header: Host[quickerbb.localhost:8080] User-Agent[Mozilla/5.0 (Windows NT 10.0; WOW64; rv:47.0) Gecko/20100101 Firefox/47.0] Accept[text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8] Referer[http://quickerbb.localhost:8080/index.php?act=register] Cookie[PHPSESSID=gq38qakmqd3j4fo6f6bl5t1su1] Connection[keep-alive] POST-Daten: username[>""
3 to 25 characters